1. Welcome to our site! Electro Tech is an online community (with over 170,000 members) who enjoy talking about and building electronic circuits, projects and gadgets. To participate you need to register. Registration is free. Click here to register now.
    Dismiss Notice

Inchworm project started

Discussion in 'Microcontrollers' started by williB, Feb 23, 2007.

  1. 3v0

    3v0 Coop Build Coordinator Forum Supporter

    Joined:
    Jul 14, 2006
    Messages:
    9,404
    Likes:
    227
    Location:
    OKLAHOMA USA
    The power and gnd come through the ICSP cable.
    Why does it not work ?
     
  2. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    i did not notice any activity on pin 8 or pin 13 when i just scoped the max232 chip
    this is R1in and R2in
    i think you are right about the com port problem , any other sugestions?
    note this is the same cable i used last night to test the serial port communications with my meter , the meter has rs232 communication capability.
    and it worked

    the signal may go by so quickly that i did not see it , but it isnt likely.the beam didnt budge.
    to sum up :
    a working cable
    a working com port
    yet no detectable signal, from the com port,
     
  3. blueroomelectronics

    blueroomelectronics Well-Known Member

    Joined:
    Jan 21, 2007
    Messages:
    12,536
    Likes:
    168
    Location:
    Toronto, Canada
    Opps my bad, yes it can be powered from the target too...
     
  4. dave

    Dave New Member

    Joined:
    Jan 12, 1997
    Messages:
    -
    Likes:
    0


     
  5. blueroomelectronics

    blueroomelectronics Well-Known Member

    Joined:
    Jan 21, 2007
    Messages:
    12,536
    Likes:
    168
    Location:
    Toronto, Canada

    Is this a USB to RS232 or a true RS232 port?
     
  6. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    its a true rs232 port
     
  7. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    pin 8 holds fast at minus 12V
    pin 13 at plus 12V
     
  8. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    i have switched to com 1
    Ran a terminal program ( from mikropsacal)
    set the flow control to NONE (in the device manager for windows) and got a signal when i transferred a file

    so the port seems to be working.
     
  9. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    i got a blip from pin 12 ! on the max 232 chip.when i try to connect.
    which is R2 out , which goes to pin 26 ,the recieve line on the 877

    so i'm gonna assume the com port is working.
     
  10. williB

    williB New Member

    Joined:
    Aug 30, 2004
    Messages:
    2,217
    Likes:
    3
    Location:
    New Jersey
    success!

    i had a bad crystal!
     
  11. 3v0

    3v0 Coop Build Coordinator Forum Supporter

    Joined:
    Jul 14, 2006
    Messages:
    9,404
    Likes:
    227
    Location:
    OKLAHOMA USA
    You have it workng, contrats.

    FWII the easyest way to test the rs232 is with a loop back type test. Remove the PIC and jumper the TX and RX pins at the processor socket Then connect to the Inchworm with any terminal program. If you can see what you type the MAX232 is working. When you remove the jumper you should not see what you type.
     

Share This Page